Requirements

To use Coherent UI SDK in your project, please make sure that the following minimum system requirements are met by your development environment and are compatible with your project requirements for the end-users.

Software Requirements

xp_logo_50x50Windows

  • Windows XP (required Service Pack 3)
  • Windows Vista (required Service Pack 2)
  • Windows 7 (required Service Pack 1)
  • Windows 8
  • Windows 8.1

Visual Studio 2008, 2010, 2012, 2013 is required to build projects using Coherent UI SDK. DirectX SDK is required for older versions of Visual Studio to build some of the samples.

Additional requirements:

  • All Windows systems must have the latest Service Pack provided by Microsoft installed.
  • Only the latest video card drivers are supported
  • DirectX shared textures require Windows Vista or later.
  • Latest drivers provided by the hardware vendor are required.
  • For Windows 8 and 8.1 only desktop mode applications are supported
  • WinRT is not supported
  • Microsoft DirectX End-User Runtime (June 2010) has to be distributed with your application (or at least d3dx9_43.dll and D3DCompiler_43.dll should be included with your application).

imagesLinux

  • glibc 2.14 or later
  • libstdc++6 or later
  • GTK 2.24.10 or later
  • GCC 4.6.3 or later

Additional requirements:

  • Only the latest video card drivers are supported. OpenGL 3.0 support is required.
  • Wine is not supported
  • Our test environment is compatible with Ubuntu 12.04 LTS

MacLogo_65x50Mac OS X

  • 10.7 or later
    • Limited support for Mac OS 10.6.8 is available, but extensive testing should be performed, and some features might not work. Use at your own risk.
  • XCode 4.4 or later

Hardware Requirements

  • Intel or AMD CPU architectures are supported (no ARM support)
  • Dual-core CPU is recommended
  • 512 MB RAM
  • 350 MB HDD space for development
  • 40-80 MB HDD space for runtime libraries

Video adapter:

  • Support for shader model 3.0 is required
  • DirectX 9.0c or later support
  • OpenGL 3.0* or later support
  • Full non-power-of-two textures support
  • Dedicated video card recommended

* Certain features of Coherent UI may be available on earlier versions of OpenGL but we don’t test that configuration and results may be unpredictable. Use at your own risk.
* On configurations with multiple video cards – SLI, Optimus, etc., the faster card should be enabled, and your users should make sure that the same adapter runs both your application and the Coherent UI rendering processes (see the documentation).

unityLogoUnity3D

  • Unity3D 3.5.7 is required
  • Only Pro version of Unity is supported
  • Mobile versions of Coherent UI SDK for Unity3D work with Unity3D Free version, but have preview feature disabled
Please note that Coherent UI SDK has different requirements than the requirements for Unity3D specified at http://unity3d.com/unity/system-requirements. Unity supports older hardware via fallbacks, which may prevent Coherent UI SDK from running on older graphics cards. Please make sure that the requirements of Coherent UI SDK match your client requirements for the project.