Requirements

To use Coherent Editor in your project, please make sure that the following minimum system requirements are met by your development environment and are compatible with your project requirements for the end-users.

Software Requirements

Windows

  • Windows XP (required Service Pack 3)
  • Windows Vista (required Service Pack 2)
  • Windows 7 (required Service Pack 1)
  • Windows 8
  • Windows 8.1
  • Windows 10

Mac OS X

Mac OS X 10.9 +

Hardware Requirements

  • Intel or AMD CPU architectures are supported (no ARM support)
  • Dual-core CPU is recommended
  • 512 MB RAM
  • 350 MB HDD space for development
  • 40-80 MB HDD space for runtime libraries

Video adapter:

  • Support for shader model 3.0 is required
  • DirectX 9.0c or later support
  • OpenGL 3.0* or later support
  • Full non-power-of-two textures support
  • Dedicated video card recommended